MOHLTC Service Issues

Incident Report for CabMD

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 13:12 EDT

Identified

The issue with HCV and MCEDT seems to be with the MOHLTC services themselves. We've contacted the MOHLTC for more information and to aid in the resolution of this issue (if required).
Posted Mar 12, 2026 - 12:21 EDT
This incident affected: MOHLTC's MCEDT Service and MOHLTC's HCV Service.