Unplanned Downtime

Incident Report for CabMD

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 14:50 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 29, 2025 - 14:42 EDT

Monitoring

As we continue to wait for Microsoft to fix a major issue - we are making adjustments to the method in which users connect to the servers. These changes should provide most with connectivity.
Posted Oct 29, 2025 - 14:33 EDT

Identified

Microsoft Azure (among other service providers) seems to be experiencing a major outage at this time. We're continuing to monitor and look at service restoration as soon as possible.
Posted Oct 29, 2025 - 12:41 EDT

Investigating

We are currently investigating this issue.
Posted Oct 29, 2025 - 11:58 EDT
This incident affected: Website Frontend (http://www.cab.md) and Website Backend (https://my.cab.md).