DNS Resolution Issue

Incident Report for CabMD

Postmortem

Service Incident Notice

Service: cab.md domain access
Date: September 11, 2025
Duration: 1 hour 2 minutes (1:45 AM - 2:47 AM EDT)
Status: RESOLVED

What Happened

Between 1:45 AM and 2:47 AM EDT on September 11, 2025, some users experienced intermittent connectivity issues when accessing cab.md. The issue affected users differently depending on their geographic location and internet service provider.

Customer Impact

  • Primary Impact: Some users were unable to access cab.md or experienced slower loading times
  • Geographic Variation: The issue affected users in different regions at different times
  • Subdomain Services: All subdomain services (my.cab.md, next.cab.md) remained fully operational throughout the incident
  • Mobile vs WiFi: Some users found switching between mobile data and WiFi provided access during the outage

Root Cause

The incident was caused by a failure in the internet's domain name infrastructure for .MD domains, specifically affecting one of the core servers responsible for directing traffic to cab.md. This infrastructure is operated by the country of Moldova and was outside of our direct control.

Resolution

  • Immediate Response: Our team identified the issue within minutes and began monitoring the situation
  • External Coordination: We contacted our DNS service provider who escalated the issue to the appropriate infrastructure operators
  • Service Restoration: The external infrastructure issue was resolved at 2:47 AM EDT, restoring normal service for all users

What We're Doing to Prevent This

Immediate Actions:

  • Enhanced monitoring of all DNS infrastructure components, including external dependencies
  • Improved geographic monitoring to detect regional connectivity issues faster

Ongoing Improvements:

  • Implementing additional redundancy measures to reduce dependence on single points of failure
  • Expanding our incident detection capabilities to identify issues affecting specific regions or user groups
  • Reviewing our domain infrastructure strategy to minimize exposure to external dependencies

Communication

We recognize that even brief service interruptions can impact your operations. While this particular incident was beyond our direct control, we are committed to improving our resilience and response capabilities.

For future incidents, we will:

  • Provide real-time status updates during any service disruptions
  • Maintain clear communication about expected resolution timeframes
  • Offer alternative access methods when available

Questions or Concerns

If you experienced issues during this timeframe or have questions about our service reliability measures, please contact our support team. We appreciate your patience and understanding as we continue to strengthen our infrastructure.

This incident has been fully resolved. All services are operating normally. We will continue monitoring closely to ensure continued stability.

Posted Sep 11, 2025 - 10:21 EDT

Resolved

This incident has been resolved.
Posted Sep 11, 2025 - 06:10 EDT

Identified

The issue has been identified. Working on resolving.
Posted Sep 11, 2025 - 02:45 EDT

Investigating

We are investigating issues with resolving our domain name currently. Some users are experiencing issues when trying to reach CabMD.

You can directly go to the site at https://my.cab.md while this incident is occurring.
Posted Sep 11, 2025 - 02:15 EDT
This incident affected: Website Frontend (http://www.cab.md), Website Backend (https://my.cab.md), and API (api.cab.md).