CabMD performance degradation

Incident Report for CabMD

Resolved

This incident has been resolved.

CabMD performance has returned to normal, and we have completed monitoring after applying mitigation steps for the database performance issue. Thank you for your patience while we worked to restore normal service.
Posted Apr 30, 2026 - 10:21 EDT

Monitoring

A mitigation has been applied, and CabMD performance is improving.

We are continuing to monitor the database and application performance closely to confirm the issue remains resolved. Some users may experience brief periods of slower-than-normal response while the system stabilizes.
Posted Apr 30, 2026 - 10:06 EDT

Identified

We have identified elevated database load as the cause of the current CabMD performance degradation and have applied mitigation steps.

We are seeing signs of improvement and are continuing to monitor database and application performance. Some users may still experience slower-than-normal response times while the system stabilizes.
Posted Apr 30, 2026 - 09:57 EDT

Investigating

We are currently investigating a database performance issue affecting CabMD.

Some users may experience slow page loads, delays when saving or updating claims, or intermittent timeouts while using the application. Our team is actively reviewing database performance and application health metrics and will provide another update as soon as we have more information.

At this time, there is no indication of data loss.
Posted Apr 30, 2026 - 09:34 EDT
This incident affected: Website Frontend (http://www.cab.md), Website Backend (https://my.cab.md), and API (api.cab.md).