MOHLTC HCV/MCEDT Issues

Incident Report for CabMD

Resolved

This incident has been resolved.
Posted May 24, 2024 - 09:19 EDT

Identified

We've identified that the MOHLTC is currently having an issue. We've reported the issue that started just before 11 am and confirmed this with other vendors.
Posted May 23, 2024 - 11:27 EDT
This incident affected: MOHLTC's MCEDT Service and MOHLTC's HCV Service.