DNS Issue

Incident Report for CabMD

Resolved

The issue is resolved, to the extent we can. We've followed up with all DNS providers involved with CabMD's sites and services, and they have found no issues. If you continue to experience an issue, it's related to routing from your ISP. Please get in touch with support, and we'll provide you with a diagnostic tool to gather more information.
Posted May 12, 2026 - 13:51 EDT

Identified

The issue has been identified as related to the upstream DNS providers. Working on a resolution.
Posted May 11, 2026 - 12:52 EDT

Investigating

We are currently investigating an issue related to DNS and reaching cab.md in the browser
Posted May 11, 2026 - 11:52 EDT
This incident affected: Website Frontend (http://www.cab.md), Website Backend (https://my.cab.md), and API (api.cab.md).