Site Issue

Incident Report for CabMD

Resolved

We've increased the resources to handle the load, and will review.
Posted Mar 28, 2025 - 16:54 EDT

Investigating

We are currently investigating this issue.
Posted Mar 28, 2025 - 16:40 EDT
This incident affected: Website Frontend (http://www.cab.md), Website Backend (https://my.cab.md), and API (api.cab.md).