API Service Down

Incident Report for CabMD

Resolved

Incident Summary
Date: July 15, 2025
Time: 4:42 am
Severity: High
Duration: ~ 5 hours
Status: Resolved

Issue Description
The CabMD API experienced a critical failure due to a missing SQL Server Native Client library dependency. The application was unable to load the required DLL file `Microsoft.Data.SqlClient.SNI.x64.dll`, resulting in a complete service outage.

Impact
- Complete unavailability of the CabMD API
- Mobile application non-functional

Root Cause
Suspected Cause: Azure infrastructure-related issue
Evidence:
- Issue occurred during off-hours with no recent deployments or changes
- Missing system library suggests infrastructure-level disruption
- Timing aligns with potential Azure maintenance or updates

Investigation Status: Root cause analysis ongoing

Resolution
1. Immediate Action: Restored the missing Microsoft.Data.SqlClient.SNI.x64.dll library
2. Deployment: Redeployed the application with the restored dependency
3. Verification: Confirmed system functionality and database connectivity restored

Timeline
- 7 AM - Issue detected
- 9:30 AM - Investigation began
- 9:31 AM - Missing library identified
- 9:34 AM - Library restored and redeployment initiated
- 9:35 AM - Service fully restored

Follow-up Actions
1. Monitoring: Enhanced monitoring for dependency-related failures
2. Infrastructure Review: Coordinate with Azure support to investigate potential infrastructure issues
3. Preventive Measures:
- Review deployment artifacts to ensure all dependencies are properly packaged
- Consider implementing dependency health checks
- Document recovery procedures for similar incidents
Posted Jul 15, 2025 - 04:30 EDT