MCEDT/HCV at MOHLTC Down

Incident Report for CabMD

Resolved

This incident has been resolved.
Posted Aug 14, 2026 - 13:56 EDT

Monitoring

MOHLTC: "Unfortunately, MCEDT is currently experiencing technical issues. The OPS IT team is investigating this issue and are working on a solution."

During an outage, particularly of HCV, the patient demographic search will not function. As it's not a required step, you can continue to add claims by manually entering the data until such time that the MOHLTC restores the HCV services.
Posted Aug 14, 2026 - 12:25 EDT
This incident affected: MOHLTC's MCEDT Service and MOHLTC's HCV Service.